CR10 Max Firmware upload issues

I have a fairly new CR10 MAX, (just over a year). I had upgraded the firmware to Tiny machines v7.4.3 because I did some upgrades. All was fine until a couple weeks ago and then I started getting errors. (Similar to another CR10 MAX firmware post " Cr10 max firmware - 3D Printer Firmware - 3D Printing Space". The system usually fails at step 1 of the bed level test, sometimes will make it to step 12-14. Occasionally I can cycle the power and make it all the way to the build, and if so, it will print. That only happens once every 5-10 power cycles. Now I have been trying to reload the firmware either Creality’s original, or several versions of Tiny Machine’s versions of the .hex file. All fail during the upload process. I’ve used X-Loader and various slicer apps to do the upload. All start and then fail.
Looking for some options to try other than purchasing another printer from a different company. Please note, I’ve downloaded several different firmware files for this printer that has a factory BLTouch and tried several different apps to load. Downloading the screen files and loading does work, but that’s done differently and is connected to a different board.

It could be the board failing. Lately my problem child of an Artillery is tossing min temp errors a new hot bed later and same error and I cannot find a fault with the old bed either.

Have you tried a bootloader? It could be bricked, or the board has died.

On another note shenzhen creality 3d technology co. ltd, seems to be owned by 3d technology co. ltd. An employee of Shenzhen PioCreat 3D Technology Co., Ltd has said they are a sub division of Creality. Shenzhen bigtreetech 3d technology co. ltd also, there are man many of the same naming convention it is hard to believe they are not all the same company. With the same problems. I hate marketing tricks.

Probably not a trick, just a lack of marketing know how and creativity.

maybe but it looks like market share to me, making a unbelievable of variations on the same theme then have 20 (?) companies owned by the same parent all making other variations.

To me no matter how you cut it is marketing foolishness. I think they are exceptionally smart marketing people at 3D Technology CO LTD. They control almost all the 3d printer market now.

Thanks for the link kitedemon, I’ve now tried that process using a Arduino UNO and an Arduino Mega and both are giving me an error during the bootloader step. Going to reset everything and try again.


I really hate messing with firmware. I love my prusa, stock no mods and I have never messed with it. My sidewinder… I have replaced almost the whole thing, It looks like it will need its third main board. Not having a PC and although the sidewinder is ‘mac’ compatable that means if you put files on a sd card you can use it. You can’t use the cable. Firmware is a complete nightmare.