Cr10 SMart Pro Extruder issue

my printer after 1 week of printing great, started printing under extruded. (prints would crumble trying to get them off the mat. I did some research and ran a flow test. I set the machine to extrude 50mm and it extruded only 11mm. went into the e-step setting and found the printer set to 103. I am not sure what it was when it was printing great. I did some calculations and set the e-step to 419.1. Prints started coming out good again. What should the factory setting be for the e-step and if it did change then why did it change. or is the value supposed to be 103 and there is an extruder issue that adjusting the e-step makes up for a failing part?
This worked for a larger 2 day print. the next time I tried to print the e-step reset back to 103. I reset it back to 419.1 but it was still slow. Adjusted to 434.1 and it was good. Tried to print immediately after this and extruder was under extruding again. Checked e-step and it was still 434.1 but now only extruding 5mm again at the 50mm setting. Machine is not reliable. Not sure if the board is bad or the extruder is bad.

I have taken apart the extruder and there is nothing jamming it. When the machine is off I can easily roll the black extruder gear with my finger when there is no filament in there. I can push the filament through when the nozzle is hot.

Any help I would be grateful for. Creality has so far been next to useless, I don’t think I can get them to send me any parts since I did not buy the printer directly through them. They wanted 899.00 and B&H photo has them on sale for 499.00

I have (at the moment, no idea where the esteps get set on the CR10 Smart Pro) - still delving into the configs, but a question - are you running the extrusion test via the control panel? or via another means?

I know from some poking, you can adjust the flow rate within the slicers, so if you’re running your test via a slicer, check the profile to see if it’s using 100% or a lower value - (SuperSlicer and Prusaslicer would use values between .9 and 1.1 under Filament Settings - Extrusion Multiplier. Creality Slicer (Cura fork) has it under Material - look for Flow. Creality Print refers to it as Infill Flow, Wall Flow, and Support Flow) If those values changed on you that could explain your prints…

If you’re doing the extrusion test via the control panel, have you also checked the tension on the extrusion spring (page 17 of the somewhat sparse manual) (which I think may be showing the wrong screw being adjusted in image A, as the one they do show, is part of the mounting bracket, and I don’t believe that has anything to do with the tension…) but, hey, I’m still delving into this thing so I may be utterly wrong. :grinning:

I thought about all of that. I had printed sliced images that work fine, I even tried to print the stock presliced files that came on the sd card.

I may have left this out But I bought a new print head and swapped it out, still same issue.

The tension screw is recessed in between the print head mounting screws.

I gave up and have setup an exchange with B&H photo. Hopefully the replacement does not have issues.

The e-step setting is under settings, advanced settings, movement and steps If I remember correctly. e-step kept resetting to 103.

ah too bad. Just saw your reply, and fired mine up and found it under Settings - Adv. Settings - Movement - Tx Rto. My extruder is set at 424.9.

Z axis is 400. X and Y are 80. May help with your replacement if the same model.

good luck on unit #2!

Thank you for those settings. and thank you for your reply it got me thinking about the slicer settings. and I think I figured out the problem.

I tried a new slicer (ideamaker) as cura was not printing the entire prints. It has half the print in Red. Could not figure out how to fix it.
So I loaded up ideamaker after that is when it started having issues.

I just went and looked at the default printer settings for the creality cr10 smart pro in ideamaker. It seams that the startup gcode in idea maker sets the e-steps. it was set to 103.

Cura does not have a startup gcode that sets the e-steps by default.

so ideamaker set the e-steps incorrectly and there was nothing in cura or the presliced images that were on the SDcard to set it back. every time i tried to print the ideamaker sliced image it would set it back to 103.

I asked creality several times what would cause the printer e-steps to change and they never addressed it.

Well, glad I helped you figure it out in a roundabout way.

I have a less problematic issue as I try to get ABL and my tramming sorted. I generated a test pattern in PrusaSlicer using their CR10 Smart Pro profile, only to discover it is doing an ABL sequence in every bit of GCode. I need to go fix that. :wink:

I noticed that the menu for the e-steps was different than mine. The one I sent back i updated the firmware as soon as i got it.

the new one I just got was having some weird movement issues. when doing manual bed leveling when going from 2 to 1 the movement would jump suddenly at the end, also when going from 2 to 4 it would stop movement in the middle and er the z a bit and then continue on to 4.

The firmware upgrade to 1.0.14 from 1.0.13 fixed this issues. my first printer I had a heck of a time leveling. I was able to get this one leveled after about 4 tries.

my process last night was
1 set z using the paper method.
2 perform manual bed leveling. (your just going for as close as you can get here)
3 perform abl. (it will mess up everything you just did)
repeat. (took me 4 times) you may have to perform manual bed leveling one for time for fine tuning.

on your first print after leveling you should adjust your z for proper filament spread. the filament purge that happens at the beginning of every print is the best to judge if your filament is at the proper height.

Good luck.

I alos have had issues with cura refusing to print an entire file. (showed up in red where it stopped) I switched to ideamaker and it seems to be printing the entire print. if you use Ideamaker make sure you set the e-step in ideamaker to 434.1. LOL

Yeah. Firmware update will happen. I am trying not to take a shotgun approach to the process so that I really learn the ‘personality’ of this printer and have a clear idea of what did or didn’t work. 25+ yrs in IT have taught me a tiny modicum of patience.

I am going on 22 years In IT. release note on the firmware are “illustrate: The firmware modified the problem of the mobile shaft XYZ direction.”

seems to me your issues may be related to that, it should be your starting point.

Just verify the Hardware version of the firmware is correctly matches your hw version in the about screen on your printer

yup. I double and triple check that. I have been down this road before with a Geeetech I3 Pro W system my daughter was gifted. I took that system from utter crap to not bad for a sub 300 CDN in price. I did have to purchase a few new parts for it as the stock steppers were meh, and the MK8 extruder just crumbled. I left off trying to get a BL touch to work on that, and bought the CR10 Smart Pro so I’d have something to make parts from. Should’ve known, I’d get yet another learning experience. All of my hobbies do that to me.

I just ran some z axis movement tests of the x axis gantry. I’m pretty chuffed. My overall left to right deviation is 0.1 mm. I can live with that.

So, firmware is looking like my next step for sure. If the drivers, or stepper motor’s were shot, I think I’d see it start to drift very quickly, or even binding (I ran from 2 mm to 400 mm a few times, and measured the gantry to the shell of the base, praying that left and right side of the base aren’t terribly out of alignment. I could get my laser level out, but meh. I’m not going 10thousandths of a mm precision here.

it is my understanding for the z axis that ABL should create and save mesh to adjust for any minor variances as long as it is not way out of wack, as for the other axis I not sure. I know the boards for these cost about $100.00 (US).
I just got into this hobby in November, Started with an anycubic Kobra go and decided it was too small. I just bought a Elegoo saturn 8k. I think this hobby is getting out of control. Good luck with that I wish I knew more but you seem to be more knowledgeable than I am. LOL

I think I read you can test the motors by swapping the cables for the X and Y to see if the problem follows the motor or follows the board. Can rule out the motor or the board that way. There is also some creality Youtube videos on testing the board and the wiring using a multimeter. I went that road thinking that the extruder motor or board could be bad on mine.

I’ve been tinkering with the Geeetech i3 Pro W for my daughter for about 2 yrs - fits and starts as work/home projects and repairs allowed. I’ve done a lot of reading, and got as deep as setting up the laptop I’m using to generate new FW for the Geeetech. As it’s a Prusa I3 clone, and a cheap one at that, with a warped bed for the heating element and glass to sit on, I had a crash course on all things that can go wrong.

All of my daughter’s prints looked like spider’s webs or for the absolute best one she got, like it had been made with spray cheese (not available in Canada, but, I’ve been across the boarder, I know what’s in the grocery stores there (shudder)).

That’s when she agreed to let me tinker. I used feeler gauges, checked the squareness, resolved the Z axis wobble issues, and actually got some prints that were passible enough. Each problem, I just dove in and read and read and read and looked at on average 4 or 5 youtube videos (some at 2x speed)

Am I an expert, no. I’d say an educated amateur. With this latest issue, I had to restrain myself from going out and buying some 1-2-3 blocks or (drool) a set of gauge blocks (Grade AS-2 would be fine aka Grade B), but I’d want to have a proper CNC milling system to justify that. I’ve made due with my Lee Valley Vernier caliper and my feeler guages.

So, after checking the silk screening on the Mobo of the system to make sure it really did match what the screen said it was I pulled the relevant FW update to 1.0.14, and applied it. rechecked the calibration, still within .1mm despite being tipped over an hauled around after one “Honey? can I use the dining room table to work on my printer … again?” manual bed level, with z offeset still at -1.65, my single layer test print is looking 90% better over the past attempts as far as the left rear and left middle squares go. whooo hooo! It’s just running the last row now, so I’ll post final results.

If you think this hobby’s expensive, try getting into recumbent trikes, then turning it into an etrike…
Actually, my photobug side is expensive too… sigh…

I’m also half tempted to build a largish gantry system, and see if I can figure out how to hook up my arc welder to “print” metal things… I’m fairly sure I won’t be allowed to buy a sintering furnace for use with metal impregnated PLA’s… sniff.

eh, maybe I have too many hobbies? naaaw. Never!

Pics Back and middle row:

Middle row and front row

So measured all 9 printed single layer squares. All of the squares on the left side have .3 and .25 mm thicknesses between top and bottom. Three going up the center line of the bed vary from .3, .25 mm to .25mm, .25mm top and bottom (most consistent is the one dead center). Using the right column of prints, and front and middle are .25, .25 mm and the rear one is .3, .3 mm. That’s not too shabby for my current needs, and I know about the last 5% taking 90% of your time so I’m going to move on!

Thanks for being a partner in crime on this journey so far! May your next prints be flawless!

you’re doing pretty good getting it level with a -1.65 z-offset. mine is sitting at -2.69 my other one was at -3.29. I am glad you are making progress. Looks prety good. I have not even went as for as yo have on getting the machine dialed in. maybe I will take the time once I have done with all the urgent prints I need to do. not that my last print is urgent bit it was the one that caused all my issues with the last printer so I figured I would start there.

sounds a lot like me with way too many hobbies and not enough time. I have not touched my DSLR in years. I have a Nikon D90. so not too much money invested into that dead hobby.

I just bought a house and have been busy with fixing stuff the previous owner rigged up. Still got a bunch more to fix. But it is good to have other hobbies to distract from it every once in a while.

My anycubic goes out of level just breathing on it. The creality i have hauled around and always stays leveled. Probably due to those extra angled supports.

Good luck with the projects. there will always be more.

BTW where did you find that bed calibration print.

well, I got too cocky… Woke up to this.

Yes, that’s the nozzle sitting there - seems it worked itself right off. The silicon shroud’s off to the side, also mildly gooped up with PLA, and yes, the front right leveling knob fell right off.

The extruder/hot end after a wee bit of clean up…this is gonna take a while to clean up and disassemble, and may well need new parts. I keep getting the abnormal temp sensor message. I do have some thermistor’s from my daughter’s Geeetech that might work… not sure… but gah.

As for the bed leveling squares, I pulled it from Thingiverse: Thingiverse-34558 - it had an stl file in it already so I simply load that, and scale the x and Y to fit my bed… X is 175% and Y is 200 or 210% I think (did the scaling in PrusaSlicer, and generated a gcode file that I just copy onto an SD card as needed - I really do need to get my OctoPi updated and configured for the Creality…)

On the house fixing up thing - yep. been there done that… battle scars of epic proportions - neither kid wants to buy a house now…

Yup. buying a few parts… sigh. :slight_smile:

I had this happen with my anycubic out of the box. I learned to go through and tighten all bolts and screws an any new printer. The any cubic was just a box of parts and you had to put it together but the parts wher already put together, but many of them were not tightened. The proximity sensor was loose causing the z- to go out of wack after every bed level attempt after 3 hours I figured out the sensor was loose and was moving each time I did a bed level. I had the z-offest to -9.90 until it would not adjust anymore. after tightening the sensor and putting it where it should be i got the z to -2.20

When I was troubleshooting my under extrusion issue I bought a creality replacement head off amazon for $89 (probably has all the parts you need and more) when that head arrived I was amazed how loose every hex head bolt was and the nozzle i could unscrew with my hands.

I had been loath to disassemble this unit. I did check all the main screws but not the grub or others buried in the print head. Ah well, this is how I learn. Heh.

Parts should start arriving today. So might be allowed to get things back up and running this week.

The print head is not that bad to tear down. there is a video from creality on how to tear it down and put it back together. The video is not named well to make it easy to find. Here it is. Service tutorial CR - 10 Smart Pro extrusion rebound check - YouTube.

BTW it may be overkill bit I always check my nozzle tightness before each print. I have to buy more silicone boots cause they rip pretty easily. I may stop checking it so often because of that. LOL

Also check the 2 hex screws that hold on the heat block. they also loosen up. if they are loose that will cause leaking out before nozzle and could cause a fire.

I noticed that about the screws. I had one fall out during my many bed leveling tests and I retightened both at that time.

Could barely undo the grub screw for the heating element when I disassembled everything on Sunday afternoon. That was definitely torqued in. The grub screw for the heat break was almost ready to fall out after the massive failure. So the failsafes worked and saved me from smokines or worse.

New heat blocks arrived this aft. I see a small design difference - no small phillips screw to help hold the thermistor in place…not even a tapped hole for it. The thermistor seems to be glued in place with a white, presumably heat resistant compound. Makes me think of muffler gasket stuff (also good if rebuilding coleman stove burners that leak fuel)

So, new heat block installed, but re levelling/tramming was a bit of a nightmare.
Realized my patience wasn’t there, so I walked away for a bit, and there were other demands on my time.

So, now, after going around on the 5 point leveling routine from the screen, I fired off a test print. Nozzle was 2.60 away from the bed if my final Z offset number is correct… that feels wrong…but, first layer print actually was almost perfect on all of the squares, so… fine. I’ll take it. It’s not that precise a tool right?

Running a set of calibration object through now, as I thought I’d had it before and everything just went seriously out of alignment… so, we’ll see. Test objects running via Creality Slicer 4.8 not PrusaSlicer 2.5… just in case. :crazy_face: