Ender 5 plus Sonic pad

After installing the Sonic pad I am thoroughly unhappy with the programming that it does all I get is error codes and messages and never can get through any of my prints I’d like to remove the Sonic pad and put my under 5 plus back to factory ability how do I do it?

I think you need to reinstall the original firmware and disconnect the Sonic Pad.

The link here should have it:

I have limited understanding of how to work with the Sonic Pad, but I believe that there are multiple USB ports on the device with it being important to use the correct USB port with the printer. Apparently, it is somewhat difficult to correctly determine what is the correct USB port.

Have you done any research into the problem? It seems to break down into:

  1. Not having the right firmware on your printer
  2. Touching the Sonic Pad’s touch screen, which inadvertently is detected as a “Emergency Shutdown”
  3. Not doing PID tuning of the hot end before printing

It is a chronic problem with the Sonic Pad and, unfortunately due to the software being used there being a fork of the basic Klipper software, the Klipper team will not support it. You’re left with Creality and they don’t have great support.

What I would suggest is:

  1. Make sure you generate a firmware image from the Sonic Pad for your printer. Use the default printer.cfg
  2. Do PID tuning of your hot end and heater bed
  3. Try a print but don’t touch ANYTHING on the Sonic Pad while the print is running
  4. Try to make sure you have the right USB port on the Sonic Pad connected to your printer. If you have a problem with one USB port, then try again with another (I believe there are two on the Sonic Pad?)

I had the exact same problems with my Ender 5 plus and Sonic Pad. The solution, in my case, was to replace the USB cable between the printer and Sonic Pad with a ferrite-core cable. And masking the +5v in this USB cable. After that no more problems. I hope this helps you further.

Still not working. Cant get n5 plus to run with tf card or computer. N5 plus is stuck on start up screen an gose no where

Try 15 cords all different. No different in the problems im having

Can you detail what you’ve done other than try different cables?

In my post above, I suggested four things that you should go through. What have you done?

I think I said it somewhere here but when the Sonic Pad works, it works. When you have a problem with the Sonic Pad, you have a problem. I think Creality’s support for the product is unacceptable.


Not only if I tried different cables I’ve tried calibrating I’ve tried other methods that have been suggested for the Sonic pad and yes you’re right when the Sonic pad works it works great mine doesn’t work at all. I am trying at the current time to try to get rid of the Sonic pad entirely by putting original firmware into the end of five I have discovered that you have to open the bottom of the machine on the back of the display there is an SD card reader that you have to put files on. And there’s more to the process still working on it. But I will say there’s a Sonic pad up for grabs it does not work for my needs

I believe the SD Card reader on the Sonic Pad is for writing firmware images for the printer.

I just looked on 3D Printing Canada’s page and I see that there is a pretty big disclaimer (including saying that paid support is available).

Honestly, it’s a problematic product and while I don’t want to knock something that forum providers sell, from the problems I’ve seen here and in other forums coupled with the lack of support from Creality, I would not recommend it to anyone.

If you want to get into Klipper and take advantage of what it brings to the 3D printing experience then you should buy a Raspberry Pi 4B and follow the Klipper installation instructions and, if you have problems, there is amazing support available from the Discourse server.