Ender 5 Pro Strange Behavior ? (Jason?)


I am a bit frustrated. A few days ago upon starting a known file, during the homing process with a BL Touch, just before the purge line was put down, the X axis was set crashing to the far left to a dead hard stop! No switch on this end. I thought ok, I rebooted the machine, loaded the same file and off it went perfectly without further issue.

I didnt think much more about it till today.

Again I loaded a known file that printed fine in the past and once the BL touch routine was complete, it sent the Z axis crashing into the nozzle and totally destroyed the bed. I rebooted the machine and attempted to load the same file. And it ran fine. No changes in Z axis offset.

My machine is having these random take offs. Was purchase a day before Christmas and was working fine till now.

Solutions please? I cant have this machine unpredictably running into hard stops or destroying more beds. The machine works perfectly between these “Events”. They are random.

Motherboard issue?

Mother Board 4.2.2
Creality Factory Firmware for the BL Touch > Ender-5 Pro- Marlin2.0.1 - V1.1.1 - BLTouch (No adapter board, as directed by Jason)


HI Trinity

Thanks for posting the issue here. That is some strange behavior, Its does not seem predictable at all. By the sound of it its almost like the motors run in opposite direction or are just ignoring the endstops?



In the case of the first instance of the x axis running away, it travelled to the end and crashed into the bearing bracket at the end of the gantry. It continued to attempt to force the hot end into that bracket I could hear the grunting of the stepper motor as I ran towards it. However it stopped and returned to home before i could get there… A current limiter I suppose stopped its action. In this case, it travelled past its software stop of X 220 and ran off the end so to speak… This is the opposite side to the switch.

In the case of the Z axis, it did the similar thing where it ignored the software stored Z axis setting and forced the bed into the nozzle while Y and X were moving. I suppose you can imagine the damage to the bed that would cause.

  1. I cannot repeat this occurrences. They are random and unpredictable. So it is not software.
  2. It has now happened on 2 separate axis. So its not a loose plug or bad wire.
  3. in both cases restarting a file saw the machine drop back into normal operations without further adjustment or change in settings.
  4. when the machine works. it works very well. Creates very nice prints. Its not making significant or even small errors during a normal print at all.

My gut is telling me there is likely a cold solder joint on the mother board. I cant imagine what else it could be. But I do need to solve this as constantly chewing up beds isnt an option. And I am concerned that the Z axis strike may have damaged the hot end but i cant be sure just yet, it seems to operate well still but who knows if something got bent.

So, I am looking for some input on how you would like me to proceed on this issue.


Greetings, and welcome to the forum.

I have an Ender 5Pro. It doesn’t come with a BLTouch. Are you sure it’s not a Ender 5 Plus (which does) or was the BLTouch an ad-on? The dead-giveaway is that the 5Pro has only one motor and lead screw raising the bed while the 5Plus has two. Otherwise, they are very similar.

On the 5 Pro, at least, there are no software limits enabled by default. I believe that can be done in software, but I’ve never bothered.

I’m going to have to put some more thought into this behaviour. A cold solder joint, while possible, is likely to only affect one axis. Also, power cycling doesn’t affect solder joints. Well, actually, it can if a system is running very hot and the power is off long enough for parts to cool down and components to shrink, which would affect a solder joint, but that’s not likely the case here.

There are a few possibilities coming to mind, none of which are at all likely, so I’m going to have to mull this one over.

As I say, I don’t want to make suggestions until I’ve had a chance to think about this some more so I don’t send you off on a wild goose chase.

My mind keep circling back to memory problems… do you have another SD card? The one’s that come with the printer are notoriously poor quality and an SD card that was supposed to read back Z-2.0 but instead reported Z-200 would explain it.


The BL touch was added on to the machine with Jasons guidance. It works correctly. It is s 5 Pro.

I was previously warned about the SD cards that came with the machines. Hence right off the bat I bought quality ones.


Welcome Trinity. This a good place too be.

I’d still be inclined to try another SD card.

We think alike :slight_smile: I already have. I just havent had time to put the other to a test yet.

Problem is, for the first instance of run away on the X, i dont know which card i was using as i purchased two 32 GB SanDisk Ultra cards. So the one that i know for sure was installed during the Z crash is now retired until i can test it.

I am watching it like a hawk.

Cheers and Thank you.

Sorry to resurrect an old thread but this problem has just started happening to me. I don’t see a resolution so I was hoping Trinity has it figured out. I have had my Ender 5 Pro for 4 years and installed the BL Touch years ago. My board is the 1.1.5. No other mods. Everything was working great until 1 week ago. I tried to start a print that I had done years ago and I found the hotend all the way to the left side crashed into the side rail and the z axis against the nozzle. I had to turn off the machine to get the steppers to stop. I don’t use a TF card since I have been using Octoprint. Now every time I try to autohome or do bed leveling or print, the hotend initially goes to the appropriate X and Y stops in the back right corner and then moves to the center y axis and far left x axis slamming into the rail and the stepper continues to try to move to the left. The z axis at this time is raising to meet the BL touch but the sensor is off the bed so the nozzle crashes into the bed if I don’t manually touch the sensor or turn off the machine. My problem isn’t random and happens all the time now. I hadn’t changed any settings in years so not sure what got corrupted. I just ordered an SKR MiniE3 motherboard which should arrive this week hoping that is the solution.