Extruder motor keeps stopping mid print

Hi guys
So whenever instart my print, after a few mins or hours later, the extrudrr motor stops. I dont know why but im sure its not the driver getting how cause it stops 5 mins after i start a print. Idk whats happening but please help+

First off check to see if the stepper motor is running hot IE: to hot to touch. It could be seizing up. After that a bad driver or motherboard, bad/loose harness connection to the stepper or possibly but doubtful bad slicer STL files.

The stepper motor does get pretty hot

You haven’t said what type of printer you have, what kind of drivers and what is your firmware.

The most likely problem is that you have your extruder current set too high and the stepper driver is shutting down due to an over temperature condition because you’re passing too much current through it without adequate cooling. What do you have your extruder current set to?

I typically run between 0.2A and 0.4A and that should be find if you have no obstructions between the extruder and the nozzle and have your heat set right for the filament that you are using.

Oh yeah lemme do that rq.

CR 10 SMART, the motherboard is a CRC 2401 (Stock), Running community firmware (Running for almost a month now without issues). I don’t know what the extruder current is so I’ll check that in a few minutes

Actually the controller is the CR-FDM-v2.4.S1_v301. I can’t find a reference to it on the Creality site.

I see references for both the TMC2208 and TMC2209 stepper drivers being used on the board, but that shouldn’t matter as long as they are serially connected to the processor and the firmware you are using can take advantage of the serial connection.

What is “community firmware”? I would like to know version and features along with the website you downloaded it from.

In any case, you should be looking at the stepper motor driver settings and see what is the current setting for the extruder (it might be a good idea to look at the other steppers as well).

I checked and all the steppers were at 1.33 except the z which was at 1.51. I turned the E down to 1.15 and it seemed to be printing fine, but after a few mins, it stopped again. The stepper is warm and the stepper driver is not even warm. Starting to feel like its the wires or smtg

The community firmware is GitHub - InsanityAutomation/Marlin at CrealityDwin2.0_Bleeding

That’s 'way too high for all of them.

Drop your movement steppers to 0.8A and the extruder to 0.5 and see how things work.

If movement has a problem, increase that stepper’s current by 0.1A until it goes away.

okay lemme do that and see

just did it and same thing happened

its after the same amount of time too

did around 3 50% benchies, 2 same gcode, first one normal current, 2nd one lower current, 3rd one, lower current + no retracts. all failed at the same layer (around 20th)

Still at 5 minutes into the print?

Is there anything on the printer’s display? Have you tried any other models? Are there any sleep settings in the controller?

Very strange but I’m sure we’ll figure this out.

Yeah somewhat around 5 mins in. I’ve tried around 3 different ones. There’s no sleep settings iirc. It was printing fine a few days ago. Maybe with another firmware it’ll magically work?

the 3 were a gear, benchy and a dragon. All failed always around the same layer count (which is around 20)

Movement is still working, but the extruder has quit?

Looking at the community firmware - are you building the firmware that you use?

Yeah movement still works but extruder quits, and no, im using precompiled firmware

Can you post a link to the firmware you’re using? Could I also get all the specifications of your printer (exact model, bed size, Z axis sensor, controller - ideally get a photograph and any mods you’ve made to it)?

Let’s see if we can figure out where the problem lies.


Screen Firmware:

Upgrades: Direct Drive + BMG Clone + Top mounted spool holder

LED Strip
Voltage reducer on hotend fan
0.4 Hardened steel nozzle