Filament Runout Sensor Light doesn't turn on

The light on the filament runout sensor doesn’t turn on, but it still prints.

1 Like

Welcome to the group.

With respect to the filament sensor, are you asking for advice on fixing it?

If so, what printer is it from?

If you do run out of filament, does the printer recognise it?

Did the light come on in the past? Is it normally supposed to come on when the filament is there, or when the filament is absent?

There are a variety of ways the light could be implemented. I’d need more information before advising you how to fix it.

1 Like

Welcome!

Personally I would either order one there are many that fit the CR10s. (Not the big tree smart sensor) They are generally around 5-8$ It is a super easy swap. If there is something not right with it but it still works correctly it could fail in the middle of a print. As a part roll of filament is far more expensive it is cheaper to replace it that wreck a print. They are plug and play it takes 3 mins.

If it is brand new REPORT IT. Too many just fix cheap printers the manufacturer (especially Creality and subsidiaries) need to get quality control under control.

Personally I’d likely still replace it on my own and perhaps end up with an extra.

A second thought. The CR10 has a textured g;lass bed? Run out sensors and limited value with ‘self releasing’ beds. If the filament runs out or shatters (too moist usually I try to break the beginning of every roll if I can I dry it, no more shatters) if you don’t get to it in very short time the bed cools and releases the print. Most of the time this will force you to start over.

Weigh the spool calculate remaining filament, and use the slicer to calculate how much filament is needed. Add a bit for errors and know if the spool will run out and baby sit it more.

With this logic you could just not use it stick a chunk of filament in and leave it alone or short it out.

Just a second option.

1 Like

I have the CR10S Pro. I tried to print without filament and it tries to print even though there is no filament in it. So the printer thinks there is filament in it all the time. Is this a software problem or do I need to change the sensor. And where can I buy this.

If you take the filament out of the filament sensor, does the light change to reflect that?

If you unplug the filament sensor, does the printer react to it? I don’t have a filament sensor on my machine, so I have no idea what to expect and, as mentioned earlier, there are different ways of implementing the light.

It could be as simple as the filament sensor cable being backwards.

When I put the filament and engage the sensor the light usually comes on. But now it doesn’t come on at all. The strange thing is that the printer thinks there is filament in it anyway and wants to print.

So…

  • The light coming on means power is going to the sensor’s light, but not necessarily to the sensor’s switch, all depending on how it’s been implemented.
  • The fact that it’s ignoring the switch means either the switch itself isn’t wired properly, the firmware hasn’t been set up to respond to it, or the GCode to make use of it isn’t in the GCode file. I don’t see an option in Cura for it, so it may have to be added manually. Maybe someone with a working filament sensor can chime in on how it gets implemented.

I did just installed the BLTouch. I got the firmware from Tiny Machines. If the one from Tiny Machines isn’t working, where would I get the proper firmware from?

When my 5 day print finishes on friday i can chip in and do a test on my cr10s pro.

I also just did the pl touch and tiny machine upgrade. If your having issues feel free to ask me/the forum here :slight_smile:

Sounds like the sensor is shorted out, effectively always sensing filament. If it worked after the firmware change it is likely physical and a new sensor will correct that. If after it could be firmware but I am doubtful it is an off on switch, nothing more, basically a deadman switch on a tractor. It works if on and everything stops if off.

To me The solution rather than messing with firmware is a new one. If it is fixed the sensor is bad if not firmware.

Most retailers that have parts will carry them. 3DPC has a great selection of parts so they are easy although spool3d will too.

Even build your own

https://www.prusaprinters.org/prints/16300-universal-portable-wifi-filament-runout-sensor-run

I updated the firmware and it didn’t fix the problem. So I am pretty sure it’s the filament run-out sensor. I just order one form Digitmakers. Hope this works. Thanks.

1 Like