Hello from Montreal

So I like to say hello to everybody. I’m got into 3D printing by learning about the INMOOV robot. Went to my local electronic store. Bought some stepper motor, ramps 1.4 with A4988 drivers and some railings. That worked fine for 2 years printing with PLA. Then I wanted to print with ABS and discovered that you need an enclosed printer for that. So back to the building … and while I’m at it let change to a 32bit board.
Got myself the Bigtreetech SKR v1.4 turbo with TMC 2209 drivers and that’s when I hit a problem. Can not get my X axis to work. When I hit the move button the controller board reboots. No matter if I have drivers and motors installed or not … always the same result. Y and Z axis work fine.
Maybe somebody has a idea what the problem could be…
Any help would be great … Thanks Gerd

Sounds like you have a short in your motor.

What happens if you swap the X and Y motor wiring?

I swaped drivers and motors always the same thing. I even unplugged all the drivers and all the motors. As soon as I hit the X move button the board reboots.

Can you move the X axis by hand? It’s not stalled?

What firmware are you running and how is the TMC2209 set up? Are you communicating with it serially or is it running in stand alone mode?

Yes I can move the axis via hand. Nothing stalled. Firmware is Marlin 2.1.1 and the TMC2209 runs in serial mode.

What you’re describing is a a voltage drop out - usually that’s a result of too much current being drawn from the power supply.

Could you please describe your printer in detail and supply some images? Along with that, could you tell us:

  1. Where you got the firmware?
  2. What are the stepper current settings?
  3. What are the differences between the X and other axes?
  4. As well as swapping the stepper motors, did you swap the wiring?

I’m sure we’ll figure out the reason for this problem.

1 Like

First of all … thanks for all the help I’m getting and I will provide all the info and pic’s. It may take a bit of time because work is calling.

  1. Marlin 2.1.1 directly form Marlin.org
  2. Steppers (Nema 17) are set at 850 mA inside Marlin configuration_adv.h
  3. I will post Pic’s so you can see.
  4. Yup I tried differenced wire …same result.
  5. I’m running my printer on 2 power supplies. 24v-13.3A for controller board, motors and Hot End.
    The other is a 24v-10A for the Bed.

Pic’s follow

How are you wiring your two power supplies? What kind of grounding are you using for the two supplies?

This question is really important as when I look at the manual for the SKR v1.4 turbo (here: https://github.com/bigtreetech/BIGTREETECH-SKR-V1.3/blob/master/BTT%20SKR%20V1.4/BTT%20SKR%20V1.4%20Instruction%20Manual.pdf) I don’t see a separate DC intput for bed power - how are you wiring it?

I’m using a 25A Mosfet module for the bed and I managed some pic’s.

Hope it helps.

Could you draw out the connections please?

Hope this helps.

is there any chance you could post up an M503 output just to see the configuration of the firmware?

Yes, that’s what I’m looking for.

Sorry, before you do anything below, I just took a look at the Bigtreetech SKR v1.4 turbo again and realized that the TMC2209s were modules - what happens if you swap the modules for X and Y? I still feel like the most likely problem is that there is an electrical difference between the two axes.

If the problem still doesn’t move then you should look at the power supply wiring as per:

I’m not sure about the “Mosfet 25A” wiring - what is the actual part that you are using here? The “Hot Bed” should be a direct connection to the positive connection to the “24V-13.3A” power supply and the “Out” is the controlled current supply. You don’t have a common ground between the power supplies, which could be your problem.

What happens if you disconnect the “Mosfet 25A” (both wires) and try the X axis stepper?

Can I ask why you put in two 24V power supplies? The 13.3A supply should be sufficient, especially if you heat the bed first. If you tell me the resistance of your 200mm x 200mm bed and the power rating of your extruder heater I can be more definite in my answer but I’m very sure you can run your printer without the second power supply and Mosfet driver.

Yes I tried to swap drivers … no difference. If I plug the X into the Y slot X works fine. So that tell me that the Motor and the axis work just fine.
Here is the info about the 25A mosfet https://www.amazon.ca/yuanz-Printer-Hotbed-Expansion-Compatible/dp/B0BR3S99YV/?_encoding=UTF8&pd_rd_w=1gW8J&content-id=amzn1.sym.0606cc44-75bd-471a-a861-3925e60effe6%3Aamzn1.symc.e5c80209-769f-4ade-a325-2eaec14b8e0e&pf_rd_p=0606cc44-75bd-471a-a861-3925e60effe6&pf_rd_r=8NC590KP87EV2RTC9JP4&pd_rd_wg=5r93z&pd_rd_r=4d72f9f9-f911-4f87-bb5a-f2ad94e8032c&ref_=pd_gw_ci_mcx_mr_hp_atf_m

I will try and disconnect the Mosfet and I let you know what happens. The reason for the second power supply in case I want to add stuff like tool changer. I guess I could run the Printer with just one supply.

Hold it - if you swap the drivers then the problem moves with it?

If that’s the case, then replace the driver module.

Hi mykepredko
I’m sorry I was not clear … no the problem does not move with the driver … but I had to disconnect my case fan (which is loud) and discovered that the X motor is making a noise and moves strange. I made a little video so you can see and hear. Hope that helps.
Ok just learned I can not upload video. Any idea how to get it to you?


Probably the best way to share the video is with YouTube - upload it there.

Could you clearly list out what is happening and what you have tried? In this last post you’re giving new information that seems to be in conflict with what you posted originally.

I would suggest that you mark the various components like:

  • X Axis Stepper Motor with “X” and Y Axis Stepper Motor with “Y”
  • X Axis Stepper Motor Wire with “1” and Y Axis Stepper Motor Wire with “2”
  • X Axis Stepper Motor Driver Module with “A” and Y Axis Stepper Motor Driver Module with “B”

Next make up a table like (which I believe are your results):

Test    X Motor  Y Motor   X Wire  Y Wire   X Driver  Y Driver   Result
1       X        Y         1       2        A         B          System Resets When X Axis engaged
                                                                 No Problems when Y Axis engaged
2       Y        X         2       1        A         B          System Resets When X Axis engaged (I believe this was your first test case)
                                                                 No Problems when Y Axis engaged
3       X        Y         1       2        B         A          System Resets When X Axis engaged (I believe this was your second test case)
                                                                 No Problems when Y Axis engaged

Now, I have no idea where the “X motor is making a noise and moves strange” as this is the first time I’m hearing that the X axis moves. In your original post you put in “Can not get my X axis to work. When I hit the move button the controller board reboots.” So I’m confused as to what is actually happening.

Thanx for doing this, it will make it much easier to figure out what’s happening.

I’m sorry things got confusing.
ok z and y axis work fine and now I discovered that X is actually moving after all. To clarify. I connected a spare stepper to the x axis and noticed that, as long as there is no load on the stepper, it moves a 1/4 turn stops and makes strange noise and then finishing with another 1/4 turn. As soon as I put a load on it it does not move at all and reboots the board. Now I verified it by removing the drive belt on the x axis of my printer and sure enough it moves a bit … stops … and moves a bit … all while making noise. I tried different driver modules on the x axis with the same result. So 2 steppers, 2 wires and 4 driver tried on the x axis and all with the same result. Turn a bit, stop, turn a bit all while making noise. I could not hear the noise of the motor because A: loud case fan B: hard of hearing (gonna have that checked my hearing)
Thanks for spending all your time on me :grinning:

When you say a “1/4 turn” - 90 degrees?

How have you configured this driver in terms of microsteps and current in the firmware? Have you enabled anything like sensorless homing?

How did you set your jumpers on the controller board? Could you send a picture of their settings along with the Y and Z axis stepper driver settings.

When I say a 1/4 turn I mean a bit and it feels like the motor wants to turn more it just does not. Lets say I want the motor to move 50mm, it moves lets say 5mm, it stops but I can feel the motor viberating, and then it moves a bit more.
Micro steps = 16
Current = 850mA
no sensorless homing