I am getting a “TMC Connection Error” on my Ender 5 Pro Screen, what should I do?

Generally, the TMC Error of the newer Ender 5 Pro machines is the result of faulty firmware. All you need to do is locate the version of the mother board (open the machine – while unplugged from the outlet – and find the version inscribed on the board itself), go to the downloads page off Creality’s website, download the appropriate firmware (based on the motherboard’s version). Once downloaded, plug in your machine, follow instructions on how to flash firmware, then flash the firmware to the printer. Printer should operate normally.

The file would be named: Ender 5 Pro Endstop file (this is for machines without a BLTouch). If you have a BLTouch, then the file name would include “BLTouch”

You can find the downloads right on Creality’s Download page: Download | Creality 3D

I have this error as well.
What exactly does it do? I’ve not been having too much trouble printing even with the error. I have been a little nervous to flash the board

Hey @Benchy it is a manufacturing defect from Creality directly. Very simple solution which was fixed by Creality (firmware update). You will need to flash the firmware!

I am having the same issue. I have been referred to the link Download | Creality 3D by multiple sources . When I click on the link and download the file that comes up when I click on the V4.2.2 is Ender-5 Pro hardware V4.2.2 firmware… ech.bvin.cpgz … which is NOT in English.
Please help me find the correct file.

I am really new to 3D printing but a tecnical person. I was disappointed to get a TMC Connection (whatever that means) error on my new Ender 5 Pro. The version number on my motherboard is V4.2.2. It seems like I would be upgrading to the same release. Is that OK?

In the process of trying to solve that problem, I decided to remove the white sample PLA that came with my printer. To my surprise, it was all broken into small pieces in the blue tube. I had to remove the tube and push the filament out with a 2 foot piece of stiff wire. OK not sure why that happened. The tension on the feed mechanism is very tight so I will have to explore that further. Did this cause the filament to break on the way into the tube?

When I move the hot end along the X and Y axis gently, with the power off, I feel very distinct detents bumps. It seems to me, this should be very smooth but it has at least 3 spots where there is this bump, in each direction. Is this normal?
All help is welcome.
Thanks very much.


Ender 5 Pro V4.2.2

Folder: Marlin2.0.1 V1.0.1 Endstop firmware
File: Ender-5 Pro- Marlin2.0.1 - V1.0.1 - Endstop.bin

Sometimes need to rename file to: firmware.bin

Turn off printer.
Use Computer and Format a 4, 8 or 16GB Micro SD chip: FAT32 4k Blocks (4096 bytes)
Place .bin file on Micro SD chip
install Micro SD chip in printer.
Turn power on.
Wait 20-30 seconds.
You will see loading screen and then home screen will come up.
Turn AC power off and remove Micro SD chip.
Turn printer on.
Use your computer to delete the .bin file from Micro SD chip, so it doesn’t keep installing!
Use printer like normal, Enjoy it!

Éteignez l’imprimante.
Utilisez l’ordinateur et formatez une puce Micro SD de 4, 8 ou 16 Go: blocs FAT32 4k (4096 octets)
Placez le fichier .bin sur la puce Micro SD
installez la puce Micro SD dans l’imprimante.
Mettez sous tension.
Attendez 20 à 30 secondes.
Vous verrez l’écran de chargement, puis l’écran d’accueil s’affichera.
Éteignez l’alimentation CA et retirez la puce Micro SD.
Mettez l’imprimante sous tension.
Utilisez votre ordinateur pour supprimer le fichier .bin de la puce Micro SD, afin qu’il ne continue pas à s’installer!
Utilisez l’imprimante comme d’habitude, profitez-en!

1 Like

Excellent advice. In my situation, when I changed from a 32GB uSD to a 16GB uSD card and renamed the file to firmware.bin it worked perfectly and installed the new firmware without the TMC error.

As you pointed out, the rollers for the X and Y-axis were too tight on the track. I located the roller axles that were smooth (no nut on the inside) and using the provided hex wrench, rotated the axle until i could just turn the roller with my fingers. At this point, there was no longer the feeling of a detent on the X-axis. I then repeated this procedure for both sides of the gantry and that eliminated the detents (bumps) on the Y-axis.

I then did a dry (semi manual) calibration of the bed using the axis positioning options in the menu. Tomorrow I will try the calibration with PLA.

Keith, thank you for your help. I’m sure that your very clear instructions will be a big help to other newbies like me. These instructions really should go on a sheet in the box with every new Ender 5 Pro.


A TMC connection error is when the Marlin firmware has been told it can communicate with the printer drivers (serial communication), but one or more of the drivers is not responding. When this happens, the default is to revert to the older, no communication setup and use the current setting from the adjustable resistor on each driver. If you are continually getting the errors, then I would recommend you check your stepper motors for overheating, and if they are… Find a video on setting the current. If you are using the Creality board, there is not much you can do since it is wired at the factory. You can troubleshoot which driver is causing the issue by compiling your own firmware and turn on Trinamic debug which gives you a few new Gcode entries… But the board has the drivers soldered in… so no real fix other than turn off the communication and set the current manually.


1 Like

Steve (sts41), Thank you very much for the very good explanation of the TMC error. The error did go away when I re-loaded the firmware as Tony and Keith instructed. This group is a great resource for someone new to 3D printing. I have been having a great time printing the little piggy bank, the display cover and the bed strain relief, all of whch came out perfect (close enough for me, anyway).
Thank you again to all of you.


Yeaaaah I updated my firmware and now I get this… anyone care to give me a heads up on what language this is?

Apparently it’s Czech. Now how the hell do I roll it back

Ha! Fixed it!

Screw you eastern Europe!