Incorrect temp displayed

Sooo this has me baffled.
I’ve been printing for literally years with my two X1s. Literally never had issues with either of them other than the typical user error and the inevitable tensioner arm break.
Then all of a sudden, about three days ago, I started a print with 3d Printing Canada’s standard black PLA and had the WORST under extrusions ive ever dealt with. I moved the spool and file to the other printer to finish the job and it went fine. I checked the nozzle for jams, checked the thermistor and thought maybe it had kicked the bucket so I changed it. Started it up again and the first few layers were fine and I got pulled away to something else but I thought it was fixed. Came back to the same terrible layer adhesion and under extrusion. Then the other printer started doing the same thing!! I thought maybe I got a bad spool so I just spent an hour clearing the nozzles again on both because I don’t have replacement .4mm on me. Then I used my fluke multimeter to check the temp of the heat block. My meter was showing a full 40C below the machine setpoint. I had the printer set at 200C and the meter read 142C. I thought maybe the thermocouple for the meter was possibly at the top of its range and decided to just run a print and see.
Sent some filament through by hand and it went fine, extruded with the touch screen, seemed okay. Started a little cube print I have, and the first three or so layers were fine and then bam, under extrusion city. I bumped the heat up on the touchscreen by 40deg and low and behold, PERFECT. FRIGGIN. PRINT. for the rest of the job. I just printed two more on each printer and manually adjusted the temp up by 40deg before the print started and it’s been flawless.
What in the FAAAAK is goin on??
I use Ideamaker to slice and Fusion to model. I have no idea how it would be possible for files from the USB to mess with the calibration of the hotend but I’m at a loss.

ANY help would be appreciated. I don’t want to adjust all my profiles up by 40deg and then have the printer do the opposite and have it burn the snot outta filament all of a sudden

Thank in advance!!



Printer displaying temperature 40C above actual temperature

I have a few questions:

  1. Have you tried a different brand of filament after these problems?
  2. On the Fluke meter, can I assume you were using a bead probe? Can I also assume that you covered the side that was not in contact with the heat block in insulation?
  3. To be clear, I don’t have a Fluke meter so I’m not sure how it’s calibrated. If you used it with it’s Fluke-supplied thermistor, the reading should be reliable, but if you substituted the thermistor that was in heat block, they likely have different temperature coefficients and your readings would be expected to be different.

Obviously, I can’t give you an outright explanation of the problem without more info, but I can relate some of my more recent experiences.

I had a roll of filament a couple of months ago that also gave me grief. I eventually found that it’s ideal printing temperature was 40C lower than what was printed on the label. The takeaway here is that every once in a while you’ll get the idea that filament that will make you wonder if the manufacturer does quality checks. Actually that roll of PLA-F that I had turned out to be one of my favourite filaments once I realised it actually prints between 190 and 200C and not the 230-245 on the label. You may be experiencing the same problem.

Print a temperature tower with it.

1 Like

Both X1s are doing the same thing?

If it is one there are a few things to look at not only filament. Them resistors are delicate and change in resistance will change the temp reading. Wire damage poor connectors and so on. I am not surprised the set temp and real indicated temps have a large variation. I am going to just toss out a few ideas.

Heat sock. It helps prevent block cooling off.
New ribbon cables, check all connections
Check connectors on the board. (sounds like you have an older model mine is a v4 and the connections everywhere were stocking.
Is the thermirestor and cartridge fitting well make sure it is not loosely goosey in the block.
cooling fan is fine? and the shroud?

Hey thanks for the reply!

So yes I did swap filaments and the problem persisted

I used the supplied fluke thermocouple to measure the temp and I removed the thermistor on the printer so I could put the junction right in the block

My issue is that everything was working fine. For quite a long time. And then both printers started acting up. What I’m really confused on is the apparent misrepresentation of temperature.
I’m going to try some different filaments and see if the problem persists.

I started a print last night after I thought I had it sorted and woke up to a bird’s nest. So I may need to replace the nozzle on that printer. Just gotta put the order in for pickup first from 3d Printing Canada.

Thanks again for helping out and if you can think of anything else please let me know!

Hey thanks for replying!

Yeah both are doing it now. It started with just being the one but now it’s both. I left a print overnight on one of them after I thought the extra 40C was solving the under extrusion issue but woke up to a bird’s nest. I think that printer may need a new nozzle. I’m going to start a print on the other one and see if it’s okay on a longer after I cleaned the nozzle and I’ll add the 40C.
All the connections seem fine, the fan and shroud are good, the thermistor was just replaced and is secure. I’ve never used a sock before but I could get one and try that too.
It just seems so strange that they both started showing the same extrusion issue one after the other basically at the same time after printing flawlessly for so long.

I’m gonna get a new nozzle and hopefully that will help the one. I’ll post later after I try the other printer too.

Thanks again for helping!
If you think of anything else please let me know

Usually on the X1s when temp starts to be inaccurate its either one of the ribbon cables or the daughtercard on the hot end. If the ends get a little corrosion on them it throws off the temp measurement because basically its measuring the resistance. About this time of year we find a lot of “bad connection” issues as the humidity level is starting to change when it coming up to summer.


I would definitely go back to using a tried-and-true filament if you have any left. While it’s common for any printer to have problems over time and while it’s expected that multiple copies of a given model will tend to share problems in common, it is extremely rare for two machines to exhibit the same problem, independently of one another almost simultaneously after years of operation. As a technician, on hearing that, I immediately start looking at external factors like changes in filament or changes in room temperature.

Speaking of which, I didn’t think of that last night: you didn’t change the environment the printers are in, did you? Move them to a different room / garage, open a window, start using A/C or otherwise move them closer to a vent?

I’m doubting everything in the above paragraph, although they are possible explanations for the change in behavior. I still suspect the filament.

If you took the printer’s thermistor out, how was the printer self-regulating? Taking the termistor out of the printer’s control loop means you can no longer trust the measured temperature taken with the Fluke to match what the printer will show on it’s screen.

Keep the original thermistor in the heat block, and bring the printer up to temperature. Once the temperature on the display is stable, hold the Fluke’s thermistor directly against the heat block using a cotton swab, or anything that won’t burn, won’t conduct much heat and which completely covers the thermistor so that the room air temperature and/or whatever you’re holding it up with, doesn’t influence it. Keep in mind that the thermistor essentially takes an average reading across it’s entire surface so if you were to hold it against the heat block with, say, a pair a needle nose pliers, it would actually be reading an average of the heat blocks temperature touching it on one surface, the much cooler plier temperature on two surfaces, and the room air temperature everywhere else. You would expect it to be reading low.

Your instinct to insert it into the heat block was correct: the Fluke’s thermistor only gives an accurate reading when immersed but in taking the printers thermistor out you essentially broke the control loop that was trying to maintain the temperature. The only reliable way to take the reading is to keep the original control loop in-tact, hold the Fluke thermistor against the block, and unsulate it so the block is the only source of warmth and cooling on the thermistor.

Wow ok
That is a good bit of insight
I’ll have a closer look
Thank you!

I removed it and held them both in the recess but maybe I’ll do as you suggested and keep the thermistor in the block and insulate the thermocouple against it. That makes good sense. I’m hoping that will make up the missing 40deg. And I’ll try a print with some overture filament that I’ve always had good results with

I’ll post back with my findings

Thank you!

oh man, I had a hard time with this issue on mine and it just went away one day. 25° too cold so like you, I printed hotter to compensate then it started being too hot one day after about a month. I was pulling the nozzle and filament out and putting the probe inside, at first with some Rockwool but I didn’t find I needed it in the end. It started getting flakey again last week, but I was able to have a thermister on hand so I swapped it out and it’s been very accurate since. it’s hard to get a reading from it when it’s all assembled with filament though I found a spot to probe it from the outside that was in lockstep with readings from inside the block and that’s how I did it mostly after that.

Both at once is very odd. I still would look at connections. 40º is a lot to find. The error rate is 5º +/- for really crappy thermirestor type probes and 2º +/- is very common. Adding 10 inches of wire for example will change the reading by quite a lot and a poor connection will do the same. Even if your measurement method is off 40º is too off.

Mine came with socks. I assumed they all did it is likely supplied on later versions because they were trying to solve a problem.

Well here’s hoping it resolves for me too! Very strange indeed
Thanks for your insight

On my replacement thermistor for the one printer I only left about 6cm or so of wire and it was working fine with it for quite some time. And the other printer that still has the stock thermistor is exhibiting the same symptom out of nowhere. So I’m still not sure the thermistors are the problem…
I do, however, really appreciate your reply

So I have a light meeting day and got to tinkering. I happen to have a very accurate (+/-0.1ºC) thermometer you know certified serial number platinum… way too expensive… Its for work.

So my prusa reads the bed temp incorrectly and same for the heat block. I measured the block with the thermometer tip pressed into the thermistor opening (opposite side) under by 3.7ºC the bed is off by 4.7ºC measured from the top (no sheet) over the thermistor.

The sidewinder reads 3.2 under same place and the bed is under by 6.1ºC. If I pinch the wires of the thermistor it reads 5.8º low. wiggling the connector I can get it to vary more. If the wires are pulled away from the heat cart leads it changes again (I am holding by hand I can’t keep it stay for stable measurements.)

My point being there is a lot of error creating into the system. The wiggling varies by more than 9ºC that’s around 18ºF.

I suspect wires or board. will be causing the issue.

Thanks for doing that!

I still don’t understand how both printers started under extruding essentially at the same time. The under extrusion is the only thing that led me to even check temps so that issue could possibly have been there all along. My error reading just may not be as precise and/or accurate as yours was.
It does seem peculiar that printing with an added apparent 40deg seems to rid the issue.

I’m at a loss and I can’t find the time to work on it in the depth that I would like so I really appreciate yours and everyone else’s help

that is absolutely odd. It seems like too large a fluke for two too misbehave at the same time.

My first guess was firmware but again two at once?

Is there any thing different in the space? The ambient air temp makes a difference (not usually that much but…)

It seems most likely global. The ribbon cables if they are used about the same amount it is possible both would go loosely the same time. At work we use a particular bulb and it is common to have 10 bulbs all go in a week or two.

I don’t know. Hmm do you have the stock hot end? The PTFE liner if you had a batch of filament over size might have pulled it out of place causing it to jam… I know it sounds like a long shot to me too.

Nope same space as ever.
I’ve reseated the ribbon cables.
One machine has Capricorn tubing and the other (the one that seems to be working just at a higher displayed temp) is all stock still.

Hopefully this added 40deg will keep them functional for the time being. I can’t afford them to both be down. I sell things that I print to order (regrettably now, I don’t print extra to stock) so it becomes problematic when they’re acting up.
Just gotta get some new .4 nozzles to have on hand.

While I have you, is there a good dependable nozzle you would recommend?

Thank you for all your time and effort!!

I run one of my 3 (ok 4 but the first is dead) almost 24/7. I tend to pull nozzles often, reprinting because the nozzle is worn out is simply too much time to save a few bucks.

I really like genuine E3Ds. I usually use the brass 0.4. I have been considering Nozzle X. I tried E3Ds hardened steel standard one a while ago but had lol temp issues, they took forever to heat up.

A friend is saying the Nozzle X is so much better that it is worth the temp things.

I spent sooooooo loooog trying to get ok prints from the sidewinder and it is the most unreliable I had. I simply cannot imagine printing commercially with one. Hats off to you. I am looking to replace mine with a Voron I hope, FAST printing. My sidewinder is slow.

I’ll pick up some e3ds then, thank you!

Yeah I’ve definitely heard that complaint about the X1s but honestly I’ve never had any issues at all until now. I love the build volume and for me they’re quick enough at this point. Maybe I’m just missing something simple but I dunno. I’ll just add the extra temp for now and go from there.
I’m luckily(?) not really busy right now but the orders do continue to come in so I gotta have functional machines.

Thank you so much for taking the time to help me out.
I really appreciate it.

I’ll report back with the nozzle swap details once I get them

Thanks again!!

I owned a Prusa first. I expected a similar experience, the first print was perfect on the Prusa it has never been modified. The sidewinder the first print was a disaster. It is now so altered it isn’t really a sidewinder at all.

I changed the hotend, steppers, belt, v rollers, couplings, most of the wiring, extruder board, fans, tightened there frame, add a bl touch, and supports for the gantry. Oh and cable relief. I needed it for a project that I had to pay someone to do because it took a 3 months to get it going.

The same stl on the Prusa and the on the sidewinder same layer height the sidewinder is slower. A 1:30 min print on the Prusa is 2:24 on the Sidewinder and the prusa makes better prints. If I slow the sidewinder down and print an a higher resolution they are about the same quality but the time adds another hour.

It still has a glitch someplace in the firmware but I use Macs so I have to beg a PC to change the firmware The result is I still use the Prusa for big prints so I am still cutting and printing chunks and gluing them together. The worst part is all the parts and shipping (I can’t even talk time…) doubled (almost tripled) the cost of the artillery. It is a really expensive cheap printer.

Sorry I am Ranting. I feel like I got had. I should have opened it up made the first print and gone DOA and sent it back.