Pc won't connect to Tevo Tarantula after firmware update

Tevo Tarantula … Screen showed I think it was Migbot, did firmware update through
Ultimaker Cura 4.12.1

Don’t remember which 1 I picked, didn’t like how it looked
Screen was very similar to this 1

Did another update, not sure which 1, and now my screen looks like this

Went to connect through Ultimaker Cura 4.12.1 and now I get

And Yes cable is properly plugged in. lol
When I plug in the cable the computer sees the printer and shows com port and all.

Checked YouTube (hours) some say to use a avrisp,

Is this it???

I thought I saw boot from sdcard but I can’t find it again!!!
I Could be wrong!!!

Yes it was Stupid just picking without Knowing!!!

Do you know off hand if the board is an 8 bit or a 32bit?

Not sure but that screen doesn’t look good

I know it’s about 2 yrs old.
how do I find out?

MKS Base V 1.4
Does this help?

sure let me have a look

Unfortunately, here is the ugly answer

It’s an 8-bit board, If the board took a bad flash you may be able to reflash it using another Arduino and reloading a boot loader onto it.

It looks like you have a kit listed there, It looks right but I personally have only ever done it from another Arduino using the jumper cables. So I cannot comment on if it will work 100%.

Here is the video I follow every time when I do it

Just to ask a silly question it was working before the firmware flash? or is this a printer you are going through to bring back to life?

Hope this helps.

Thank you for researching this :grin: :grin: :grin: :grin: :grin:
I Never would’ve known Where to Start!!!

If I understand right I would use this to replace the boot loader (I’m assuming the firmware is
different then Tevo) then using (I understand the Jim Brown version is the best firmware!?!?!?)
to update the firmware.

It did work good other a shifting problem, but I blamed that up to the bed springs lmao

The shift is in the X-axis.
After this print I was considering the firmware, so I decided to update it.

1 Like

I just noticed that was a Creality3D board, I would have to translate the pinning to
the MKS Base board…Right???

Or Would it be easier to Replace the MKS board???

1 Like



your board on the tarantula is able to be flashed without any extra stuff, I can link you the video i used. right now your board looks like its “bricked” but this should help! also, download arduino and get the firmware from the github link in the bio of the vid, I say dont do any of the changes in the vid until you know that it works.

1 Like
1 Like

I did what he said in the vid, didn’t change anything like you said.
Made sure about the Motherboard, and stuff
He said about the board and processor (I Hope they’re the same, don’t know where to check)


Hit load and nothing.
And the screen is the same

When I plug in the usb the pc says hello (beeps lol) I check devices (control panel) and the printer
shows up.

Went to connect through Ultimaker Cura 4.12.1

This is what I get when I connect.

1 Like

dont upgrade through cura ever

1 Like

you have to press the button in arduino and let it compile and burn onto the printer. it takes like 10 minutes when you do it for the first time.

Now Ya tell Me lmao

It ended with errors!!!

I remembered what Jason posted

Unfortunately, here is the ugly answer

I watched it again. , followed it, then realized it’s for a Creality3D board,
Then found this 1 for the mks board

Picked up a Arduino Uno

followed it through… loaded Jim Browns Easy config… Didn’t change a Thing in
the firmware…

It Works… :grin: :grin: :grin: :face_with_symbols_over_mouth: :face_with_symbols_over_mouth: :face_with_symbols_over_mouth:

So Far I don’t like the settings!!!.!!!.!!!
On stop the head goes to the front left and the motors stay Locked…!!!
I’ve got some learning to do on ReConfiguring!!!.!!!.!!!

Got more heat Alarms then prints

Love to find the Original Firmware

All In All Thanks Redracefpv and Jason

1 Like

mine keeps giving me alarms too, ya should not have needed the uno but good luck.

HI Guys, Thanks for jumping in on this one, Got called out of town on a family issue. Just checking in on the forum in the evening.

@Bill_L glad you at least didn’t damage the board, I am sure someone will have the original firmware out there if you still need it.

Most of the time you will find the original firmware from the manufactures website. If you cannot find it there have a look at github or the forum. Usually someone will “remake” the original firmware and make it a little better. Just remember to install the one with the options you have on your machine, BLtouch, Filament sensor etc etc.

Mostly your layer shift looks like a binding on the X axis or maybe a loose belt. I doubt if you are ainto Vrevs or anything like that at this point.

Let us know if you need anything else.

It went off 6 times before it would print, then 1 time it went off a few mins into the print!!!
I pulled the thermistor out, and it Looked Ok

This is the alarm, 1st screen, then after a second the 2nd
Just before this, temp goes up then varies between 199 and 209 for a min or 2

I tried to update straight to the Mks Base C1.4 board with Arduino…Thinking I did something Wrong through the Uno,
and this is what I got

The 1st time was different, it had a long page
This is the error that came up

Arduino: 1.8.18 (Windows 10), Board: “Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)”

Sketch uses 155424 bytes (61%) of program storage space. Maximum is 253952 bytes.Global variables use 4746 bytes (57%) of dynamic memory, leaving 3446 bytes for local variables. Maximum is 8192 bytes.avrdude: stk500v2_ReceiveMessage(): timeoutavrdude: stk500v2_ReceiveMessage(): timeoutavrdude: stk500v2_ReceiveMessage(): timeoutavrdude: stk500v2_ReceiveMessage(): timeoutavrdude: stk500v2_ReceiveMessage(): timeoutavrdude: stk500v2_ReceiveMessage(): timeoutavrdude: stk500v2_getsync(): timeout communicating with programmerAn error occurred while uploading the sketch

This report would have more information with
“Show verbose output during compilation”
option enabled in File → Preferences.

Tried again straight to Mks Base C1.4 board

The only thing I changed was the Printer Name…

I hit upload Well over an hour Before
This is a far as it got

Try some more things today, Different computer even!!! :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face:

1 Like

I Hope Everyone is OK

On the search for a Remake.
The belt is good, I held the drive gear tight with 1 hand and moved the head with the other and it wouldn’t skip and there’s nothing in the way.
No idea what … ainto Vrevs is/are

1 Like

The printer worked fine before (other then the shift problem)
Could it be that something else happened
Like could the thermistor or something else cause this, yesterday I did take it out, made sure it
was clean and all the connections are tight.

If it could be the firmware, Any idea settings I should I look at?

1 Like