Persistant layer shifting

I have an Ender 5 plus which had been pretty steady for the past year but now even the easiest of prints seems to get layer shifting… sometimes on the X and some times on the Y axis… I though it was a blob issue which I seem to have fixed with a new silicon sox but once again it happened last night…

any idea’s what it coule be?

The simplest thing is something is getting snagged somewhere. Before doing anything else check the cables to be certain you are not catching something. I tend to use the interface to move all the axis to the fullest extents. I can watch and be certain they are not hanging up someplace.

1 Like

If you could provide a photo, that might be helpful too.

Hi,
I am using an Ender 3 Max and I started having layer shifting issues 2 months ago. After searching the web, I found various suggestions but the one that seemed to make the best improvement was grounding all the motors to the power supply enclosure (frame ground). In the process, I changed the control board not long after I grounded the motors. I think the motor drivers were partially damaged by the electrostatic discharges. Using the new board seemed to improve a little bit more.

How and where are you measuring the voltages? These are 24V stepper motors.

on the little potentiometers beside each motor driver on the control board. The voltages i tried did not make any difference to fix the problem.

Hi @Reynet69

I have a couple of the 5plus in my farm, they were notorious for layer shift. I realized it was the wiring that comes from the rear right corner of the machine to the extruder was getting hung up randomly.

I use the of those retractor reels and zip tied it to the wiring and screwed it to the wall. haven’t had a shift since.

sorry might be a little easier if I actually posted the link… One of those days

thanks for the suggestion I’ll double check

wow interesting I’ll keep it in mind.

197484450_390376608968036_466050094167870065_n

this was last nights results after realising that the fan in the power supply was jammed… so power supply fan wasn;t the issue and the stepper motor fan is working fine :frowning:

That does not look my motor grounding issue. Is possible that something is blocking the movement? A cable catching on something? When it skips, to you here any noise?

I’m almost certain you’ve got a cable catching on something.

2 Likes

Always check the cables first in a layer shift it takes no time and is often the culprit!