Shutdown due to webhooks request

Creality Sonic Pad error says shutdown due to webhooks request and stops my print. So I’ve now gotten this error on every print except 2. Out of 11 prints only 2 were successful, this is sooooooo frustrating as a Google search returned hardly any results. It happens at random times… I’ve had it come up anywhere from 8% completed to 92% completed prints and I’ve now wasted a toooon of filament. The two that finished turned out great. I’m not sure where to begin troubleshooting as I’ve no clue what that means or why its happening but Ive tried 3 different USB cables as to eliminate that as being an issue as the only Google search user that had this issue that was his fix. Please any help would be appreciated as I’m no longer using my printer cause I’m wasting waaay too much filament for a 20% chance I’ll actually be able to have a print finish without this error occurring. Ender 3 Pro with Marlin firmware and Creality Sonic Pad is what I’m using…

1 Like

I just saw that you just posted this on the Klipper Discord Forum. I’ll be interested to see what the experts there say.

The Creality Sonic Pad uses a fork of the Klipper host software (and KlipperScreen) and does not generate a klippy.log file. From what I’ve read, when it works, it works great. If you have a problem, you have a real problem as support is not great for the product.

My recommendations are:

  1. Make sure you have the latest Sonic Pad firmware. Apparently there was a new release about a month ago.
  2. Install (the Creality) Klipper firmware on your printer. I know that Marlin is “supposed” to work with the Sonic Pad but I’ve heard of other people having problems that were resolved by going with Klipper firmware.
  3. Putting Klipper firmware on your printer means that you’ll probably have to retune your printer and work through the printer.cfg but Creality has a default printer.cfg for the Ender 3 (or at least should have) so that should reduce your workload.

Sorry, I can’t give you better news - let us know how you make out and I’ll watch the Discord forum.

1 Like

Thanks for the reply, so your suggestion is to eliminate Marlin and just install Klipper firmware i stead. I’ve heard its a pain to do but Im willing to try anything cause right now the printer ain’t gettin used lol. Hopefully by now there’s some good walkthroughs on how to install Klipper…

1 Like

The Sonic Pad has a Klipper Installation Wizard which should guide you through the process of creating the Firmware.

1 Like

Is that different than the initial wizard that installs upon initial use of the sonic pad?

1 Like

I have no idea - I don’t have one. Sorry.

When I look online it says that the Installation Wizard generates the Klipper firmware for the printer - I presume a .bin file is produced that you put onto an SD Card which changes the printer’s firmware.

1 Like

Yes that is correct. I wonder if I should refash the .bin file of Klipper it creates… I guess it couldn’t hurt at this point

1 Like

Give it a try - you can always revert back to Marlin.

So I am having this exact same problem, just started yesterday. I have determined it’s not the Sonic Pad though because I have two Sonic Pads and two Ender 5 Plus. I am having the problem on the one printer only and it doesn’t matter which Sonic Pad I set up on the one having the communication error. Both of my Sonic Pads work perfect on my second Ender 5 Plus and they both get this error on the my first Ender 5 Plus. This tells me the issue is on the Printer side and not the Sonic Pad. Both my 5 Plus have the silent board upgrades so I am going to try switching out the board for a different one and see if that fixes the issue. I will update shortly.

1 Like

I need to do more testing when I get time but after tuning PID for the hotend and hotbed I was able to do two successful back-to-back prints one was short like 15 minutes the other was almost 2 hours long with no errors… I don’t want to jump the gun and say my issue is fixed but it’s looking quite promising. I’m going to do more prints this weekend to see if the error occurs. I really hope not lol


Was that with the Klipper firmware?

Im getting the same error with klipper firmware but im just in the setup faze right now, its every time i try to heat my bed to 60c i get that warning pop up after a few minutes of heating. Im currently pid tuning the bed now but same again im having to pid tune it at 40c because if i try to tune it to 60c i get the error again :roll_eyes: I’ve currently been at this for 2 days first it was the firmware wouldn’t flash, then it was the printer.cfg file wouldnt load and now its this! It just seems never ending :pensive:

Yes that was with klipper

1 Like

Sineos replied to you on the Klipper Discord channel - you should update that forum and note that you need to run the Sonic Pad generated Klipper firmware.

Cool thanks for letting me know and I did update that on the forum. Really hoping that the PID tune fixed my issue. Three successful Prints in a row yay!

1 Like

So i think that fixed the issue as I’ve been printing all day with zero errors so if anybody is coming across this issue I would do the PID tune settings within the Sonic Pad as a possible fix.

So I just did the the PID calibration and now I’m doing a 9 hour test print. Will update tomorrow if it was successful. Would be nice if that’s all it was.

Update: The print crashed about 1 hour into the print. I watched it close and saw what the issue is. The Hot End started fluctuating too much on the temperature. It held the temp for an hour and then started dropping and couldn’t get back up to the setpoint. Once it dropped too far the system stops. Again I know this issue isn’t on the Sonic Pad side because I’ve switch between two units on two identical printers and the issue is only on the one Printer so the board is coming out!

That sucks but at least you were able to determine what the issue is. I didn’t think it was the pad at fault but it definitely is tied in with the temperature reading at the hotend. I’ve printed all weekend now, 9 prints and not one error apart from them all stopping at 99% which I’m sure is something in the Gcode

New Update: Problem ended up being a faulty thermistor. Replaced it and everything is working now. It would be nice if the error code wasn’t “Shutdown due to Wehooks request” and instead “couldn’t maintain hotend temperature”