Standard Ender 5 Hemera Upgrade

Hi there,

I recently bought an Hemera Direct drive kit for my Ender-5, the standard version. The assembly and all went fine, but i’ve come to the part where i need to change my firmware, or so i’m told.

I’m not really into programming so this part is a bit of challenge for me. The video of the ender-5 plus from 3D Printing Canada was pretty useful so far, but I’m still struggling. Can i just follow the instructions of this video for my printer, or is the firmware of the ender-5 different form the ender-5 plus. Could somebody please help me and maybe explain to me what i’m supposed to do.

I’ve read in a previous topic that there may be some prebuild firmware that I could use, if I’m correct. Where can I find that and is that just installing and plugging into my printer?

Also, what happens if I use my printer before I upgrade the firmware? Is it just some problems with coördinations, or doesn’t it run without the upgrade?

Hopefully somebody can help me.

Groetjes, Koen

HI Koen

Welcome to the forum, Glad you found us here in our corner of the web,.

If I can understand correctly if you are just changing to the Hemera and nothing else it seems to me the only thing you need to change is your e-steps. You can do this with an M92 command through Pronterface or any similar terminal software. No need for new firmware. Even if you have to adjust your offsets you can do it with an M851 on the same interface.

Firmware modifications are required if you are going to change hard settings in your printer, Bed size, Whether you have a touch or if you are wanting to raise the Max temp for your hot-end. These are considered Hard limits.

mostly anything else can be modified with G or Mcode.

Let us know what specifically you are looking at changing I am sure we can get you in the right direction.

Hi Jason,

Thanks for your answer.

I’ve changed the e-steps with help of your video. It was very helpful, but i’ve still got a few questions.

At 34:50, the instructor says that I need to check if the “default_envs” is correct.
In the video this needs to be “megaatmega2560”.

I checked the board that is in the ender5 via platformio.ini and it says it is a “sanguino_atmega1284p”.

Does my default_envs" need to be “sanguino_atmega1284p” or “megaatmega2560"”?

Also, the video shows something happening with the screen files. Do I also need to touch those??

Last question, but this one may be very obvious, how do I need to insert the files in which I changed the esteps, in to my printer? Is there a special micro-usb slot?


Hi Koen

sorry for the delay in getting back to you, I was off for a few days.

I would set the steps via the M92 command and you shouldn’t need to change the ENV variable.

Usually, you are setting this for updating the entire firmware, I generally don’t recommend firmware changes for a minor update such as e-steps.

That being said I cannot be certain which ENV you will need as it depends on the mainboard installed in your printer. If you have the creality version number I can see if I can track down the correct ENV for you.

Hi Jason,

Thanks for your answer, I think its getting a bit more clear for me right now.

This version number you’re asking for, is it the same number as the one as the number on the barcode sticker? Or do i need to look at my mainboard?

HI @Koen

You would have to open the bottom of the printer and look at the version number on the mainboard itself.

Unfortunately, they do not write it on the outside of the printer.

All what I could find was: “200101051 Creality3D V1.1.4”.

Is that the information u need?

yes, that’s right its a version V1.1.4 board.

Hi Jason,

I Just read the whole thread again, and I’ve downloaded Pronterface.
you told me to use an M92 command to change the e steps, and so I did.

In Pronterface I typed “M92 397” as E3D recommends this amount of steps for the hemera and I sent it to my printer. Now the console says “SENDING: M92 397”. does this mean my e steps have changed?

When i tried to move my extrude via “move axis” in the printer menu, i didn’t see the gears turn.

Also it seems like i have about 6 mm of z offset. Do you perhaps know any simple tips for the ender 5 on how to change this?


Hi Keon

very close, you have to tell it which axis you are modifying the steps for. The command should be this

M92 E397

Then when you are done you type just M92 and it will display the current steps, you should see the new value. When it’s correct ensure you type M500 to save your changes.

Hi Jason,

Thanks, I did what you said, and the console displays the right amount of steps. But now i have another problem… the gears won’t move when i tell them to. I think it has something to do with the wiring from the main board to the stepper motor.

I find it difficult to understand what wire should be connected to what pin on the stepper motor. I already tried what hemera suggested on their website (changing the to middle wires) but that wasn’t successful. Do you have any tips for me on what to do?

Groet Koen