BSOD on Ender 5 Pro after shorting thermistor

Hi, folks.

So, last week I’d had a bad nozzle clog. As I was removing the nozzle to clean it out, I loosened the heat break (Micro Swiss all-metal hotend). After cleaning up the nozzle and putting things back together, I wanted to make sure the heat break was solidly in the heater block. My understanding is that it should be tightened once more after the block is hot. So I duly heated everything up to 220 (what the instructions recommended for tightening the nozzle) and got in there with the little spanner.

Alas, I managed to touch the spanner to either the heater cartridge wires or the thermistor (probably the former) and created a short. One big spark later, my thermistor is fried (no shock) and the LCD isn’t responding. Power off, power on and… nothing.

The LCD lights up, but doesn’t display anything. I’ve replaced the thermistor, that didn’t help. I also reseated both ends of the LCD’s data cable.

I have a 4.2.2 board. The blade fuse is intact and a blue indicator LED comes on, as does the hotend fan. All the status lights on the power supply look good - and obviously, power is getting out. There’s no obvious burns or melts on the motherboard.

At this point my best guess is the short either fired something subtle, or blanked the EEPROM. Any other ideas are of course very welcome!

Short of replacing the motherboard, does anyone have any suggestions for troubleshooting or repair?

Let’s do the easy things first. Turn the printer off and unplug everything (stepper motors, limit switches, bed heater, hot end heater, etc. Leave the LCD plugged into the motherboard. You can do all this without opening the case. The cables all have plug/socket combos. Just separate them. When you do this, just be sure they still have their original labels attached so everything gets back in the right way.

With everything except the LCD unplugged, turn the printer on. If it starts with no external loads, plug in the limit switches and re-test. If OK, turn it off, plug in the steppers and re-test. Power off and plug in the bed and hot-end thermistors and re-test. Next, repeat with the bed heater, then repeat with the hot-end heater.

If at any point it fails, the last set of components you plugged in are a clue to (but not necessarily the cause of) the problem. It is highly, highly unlikely that the limit switches or stepper motors or bed components are an issue. I’m just including them to cover all the bases. Most likely it’s either the hot-end thermistor or hot-end heater circuits.

Note that I say “circuits” because it’s not just the external parts that can be causing a failure to start up, it could be the parts of the controller board they are connected to.

My greatest suspicion is that it’s the internal controller board. I only suggest all of the above because a standard procedure with testing any kind of computer is to remove all the peripherals (and stepper motors, limit switches, etc. are peripherals in this case) and the design of the E5PRo is such that you can do all these tests in less time than it takes to remove the controller board. Those tests, even if they don’t conclude anything, should take you less than 5 minutes.

Now for what I really think is likely the problem:

I’ll assume if you’ve had to come this far, that the printer still failed to start with everything unplugged.

The fact that the fan and lights come on does not mean that the supplied voltage is correct.

At this point, you will need a volt meter and you will have to take apart the bottom of the printer. It’s probably a good idea to unplug the printer itself while you take the bottom panel off.

Remember that you are now working around exposed 120V wires. Pay attention to what you’re doing.

Once you have the bottom panel off, plug the printer back in and turn it on. Measure the voltage being supplied by the power supply. It should be very close to 24V.

If it’s very close to 24V and the printer isn’t starting, there’s a very, very slim chance the LCD has failed so we’ll test for that further down, but first…

If the power supply voltage is significantly off from 24V, unplug the printer. Photograph the arrangement of the wires that connect to the power supply so you can plug them back in in the correct order later, then remove all the wires coming out of the power supply except the AC cable. We want to test the power supply with absolutely no load. Once you’ve done this, plug the power cord back in and test the power supply again.

If the voltage continues to be significantly off 24V, there is a small adjustment potentiometer at either the right or left side (depending on the power supply model), off the end of the row of terminal screws. With a volt meter monitoring the output voltage of the power supply, slowly adjust this potentiometer to see if you can get it back to 24V. If you can’t, the power supply needs to be replaced.

If the voltage reading is close to 24V after you unplug all the loads, you will need to see if the voltage remains at 24V with a heavy load on the power supply. If you have a spare heating element for either the bed or hot-end, wire it across the 24V output of the power supply, then plug the power supply back in and re-test. If you don’t have a spare heater, you can remove the bed heater cable from the controller board and wire it directly to the power supply, then plug the bed (yellow connector) back in. Turn the power supply on, verify the bed is heating and check the power supply output voltage. If it’s not maintaining 24V, the power supply needs to be replaced.

Keep in mind when you do this that you are using a heater directly and without a control loop. It will gradually continue to heat until it either reaches equilibrium or destroys something. Don’t allow yourself to get distracted. Do the test and turn it off.

So, if you’ve reached this point, the power supply is maintaining 24V under load and that just leaves the controller board as the problem.

Unplug the LCD from the controller board. Reconnect the controller board’s power supply connectors to the power supply and turn it on.
Plug a computer into the printer’s USB port.
You’ll need a serial communication terminal program. I use the one that comes with the Arduino IDE. You can get it here:
To start the terminal on the Arduino IDE, go to Tools->Ports to select the port the printer appears on. Then go to Tools->Serial Monitor

If you use a different terminal program, the steps are basically the same: Select the port the printer appears on.

You then need to change the baud rate to 115200.

In the Send window, type M503 then hit enter.
The printer should report back a list of its settings.
If that worked, then the motherboard’s computer (and USB port) is at least running. That does not mean, though, that the rest of the motherboard is working, including the LCD drivers, nor does it mean that the LCD itself is actually OK.

Frankly, I’m not sure how to test the LCD independently other than by plugging it into a known-good printer.

If the USB port test didn’t work, then, given that the power supply has been tested OK and the rest of the peripherals are not even plugged in, then you almost definitely have a bad controller board.

If the USB test DID work, then there is another easy test to do:

Reconnect the stepper motor cables.

Since you still have the computer plugged into the printer, go back to the terminal program Send window and type:
G0 X 20 and enter.
The X axis should move 2cm
Similarly, G0 Y 20 should move the Y axis and G0 Z 20 should move the Z axis.

If all this works, then the controller is likely OK and it suggests your LCD has been damaged, but as I say, I don’t know how to test that independently.

At this point, I’ve been typing and testing for nearly 90 minutes and have made so many edits that I apologise if it started getting incoherent. Feel free to ask for clarification.

Well, thank you for taking the time to make a detailed reply! 90 minutes was a huge chunk of your day, and I appreciate you using it to try and help me.

Booting with no load made no difference. This was not a surprise, really, as both the power supply and motherboard status lights were showing normal status, and there were no indications that there was a brownout occurring. But as you say, when one has no idea what to do next any idea is a good one.

My multimetre confirms that the power supply is putting out ~24 V (24.24 to be precise) under both load and no-load conditions.

I don’t have a lot of experience with LCDs, but I do have a little, and from what I know of their fail-states I think it probable that the LCD is working properly and just not receiving any information. If I can figure out its pinout I’ll try hooking it up to a microcontroller to make sure, though.

Unfortunately, trying to use a serial terminal though the USB is a non-starter at present. I have never managed to convince my (Windows 8) laptop that the printer exists when plugged in via USB, and not shockingly it still doesn’t work. I’ve no idea what that issue is, and it’s very possible it’s a hardware problem on the laptop.

In theory, hauling the 3d printer down to the desktop I’m using right now is possible. That will take more mental & emotional energy than I have at the moment… but I’ll add it to the list of things to do when I’ve got the spoons.

Since that will probably take a few days, I wanted to post this update for any other readers; and to thank you for the suggestions.

I also tried reflashing the firmware via sd card, to the expected no result.

At this point my gut is that I’ve either fried the processor or blanked all it’s onboard memory; with either of those conditions replacing the motherboard is probably the only solution… well, you’ve given me ideas of two more things to test before I get to that stage, so, again, thank you!

Well, progress is progress, even if it’s to eliminate non-problems.

First, an FYI for your general knowledge going forward:

LEDs typically require about 1.2V and 10mA of current. As long as they have at least that much, they’ll light. The printer uses 24V for it’s motor control circuits, 5V for some of it’s logic and backlighting on some LCD models and serial communication circuits and 3.3V for the processor. If any one of these fails, the printer will fail, but as long as the power rail the LED is connected to has power, it will light. There exists some equipment (not necessarily printers) in which the internal computer boots up, performs a self-test, performs a system-test, and if all is well, lights an LED, but this permanently ties up one of the processors I/O ports but most 3D printers don’t have an enough I/O pins to spare for an LED few people are ever likely to see. Moral of the storey: treat LEDs as idiot lights. They’re only truly meaningful if there’s a total power supply failure. This, of course, applies to the light in the power supply as well.

That’s why I had you go thorough those steps in spite of the fact you had already indicated the LEDs were lit.

End of FYI

On my desktop Linux system, I have two easily accessible USB port connected to two different internal USB busses. One of them always detects the printer, the other one never does. I have no idea why. You may just need to try a different port.

For future reference, doing something like attempting a firmware update is risky because it introduces another potential point of failure. When debugging something, never do things that add more risk.

So yesterday I realised I didn’t actually need to haul the entire Ender-5 downstairs to test the motherboard. I just needed the motherboard itself!

Of course it would need power but I have a bench power supply for testing electronics next to my desktop computer. So, I dismounted the motherboard, brought it downstairs, fed it power, and plugged it into my computer via USB.

Aaaand – nothing.

I have not been able to get the computer to see a device; not even a device it didn’t know what to do with. As far as my computer is concerned, the printer’s motherboard just doesn’t exist.

There are now three possible conclusions: either a) Windows 10 is being annoying; b) the USB on the motherboard is kaput (supported by the inability of my laptop to see it too); or c) the motherboard is fried (supported by the entire reason for posting). Of course, combinations are also possible.

Since I can’t think of any way to test if it’s just the USB, I think I’m into “replace the board” territory.

If anyone has any further ideas, I’d love to hear them; but I think that tomorrow evening I’ll be ordering a replacement board.