Creality Ender 5 Pro + new motherboard : How do I flash the firmware?

Tried to flash the new firmware on. Copied Ender-5 Pro- Marlin2.0.1 - V1.2.1 - Endstop - Filament - TMC2225.bin to the SD card, removed other files, unplugged the 3D printer, put the card in, plugged in printer and turned it on…wouldn’t flash.

Tried renaming the firmware file to FIrmware.bin, deleted other files on the card (added by the 3d printer: EPROM.dat), unplugged the printer, plugged the card in, and powered the printer back on. Still no luck.

What am I doing wrong?

HI Derick

what is the version number of the mainboard you are installing? might be an 8 bit board and have to burn a boot loader on it?

Jason H

My board is a 4.2.7 32 bit official Creality board.

Link to where I got it from:

seems like you’re doing everything OK, Did you format the card using 4096 byte size,? looks like the board is not reading the bin file or the firmware is same version as what’s on it. Try flashing an earlier version number and then flashing again with the newer one.

When I do an About Printer on my Creality Ender 5 Pro, I see this:
Marlin
Ver 1.2.1
2020-04-25

I downloaded my firmware from here:
https://www.creality.com/download
28 Jan, 2021
Ender-5 pro 4.2.7mainboard(32bit).zip

Tried quick formatting my SD card to 4096 byte partitioned FAT. Still no luck.

I noticed my 3d printer always writes this file on it:
EEPROM.DAT

yes the Eprom.dat is normal, its actually the printer using a part of the SD card for swap space and settings being saved in.

just for curiosity, how large is that SD card?

7 GB card. The same SD card that came with the printer.

Try to rename the file to firmwaretest.bin and see if it will flash with the new filename?:

Tried renaming and still no luck.

seem to remember reading a bug somewhere you had to call it firmware.abc.bin, if that didn’t work you would have to rename it to firmware.bcd.bin something about different filenames but not firmware.bin or it wouldnt work. trying to find the article in my history.

Thanks so much! Your efforts are greatly appreciated!

Should I switch to a smaller size SD card?

no the size of the SD should be fine, Just wanted to make sure it wasn’t something like a 128Mb that does not give enough swap space to complete the operation.

The article I was was on TH3D website, they have a note about it having to change the name of the firmware. bin file

Thank you sir. I tried building the code as per the article but I get an error during compile time indicating sdkconfig.h doesn’t exist, and then the build stops.

For reference:


#include “sdkconfig.h”
^~~~~~~~~~~~~
compilation terminated.
*** [.pio\build\STM32F103RET6_creality\lib7aa\ESP32 BLE Arduino_ID1841\BLEAdvertisedDevice.cpp.o] Error 1
============================================================================================== [FAILED] Took 17.85 seconds ==============================================================================================

Environment Status Duration


STM32F103RET6_creality FAILED 00:00:17.851
========================================================================================= 1 failed, 0 succeeded in 00:00:17.851 =========================================================================================
The terminal process “C:\Users\Derrick.platformio\penv\Scripts\pio.exe ‘run’” terminated with exit code: 1.

looks like there is an environment variable not set within VS code

Its appears as though it cannot find the source file SDKconfig.h

BTW, just to confirm, I am using an official 32 bit Creality mainboard (with silent motor drivers) which I purchased from 3d printing canada. Does that come with a bootloader? Does it support update by just plugging in the SD card?

HI Derick

Yes all the 32 bit boards come with bootloaders already on them

Jason H