CR Touch on an Ender5 pro

Has anyone out there had any success installing and setting up a CR Touch on an ender5 pro. I have tried everything I have read and I can’t get it to work. I am thinking of returning it back to stock and perhaps selling it on the local buy and sell and getting a unit with auto level installed. Any ideas anyone?

hi @vernonmr

Do you have a pic of the wires where they are installed? do you know where the firmware is you used? or where you got it from.

The firmware and the location of the plugs for the BLtouch (CRtouch) are depentant on each other.

Its the firmware that tells the printer where to go look for the pins and then the G29 takes over from there.

Lets start here, What is the version of the board you are using? and where did you get the Firmware.

Past that is THE Cr touch depoy and retract twice on boot of the printer. Are there any lights on it? flashing or otherwise?

We can get it going I am sure.

I took pictures of touch and the motherboard but am not sure how to send. This isn’t my thing. Board is 4.2.2 firmware was from Creality site ender series firmware, Ender5 pro 32bit mainboard. This turned out to be in Czech. I downloaded another copy from the Creality forum installed and set it up according to the instructions on the CR installation sheet. If you disable steppers place print head in far rear corner and do an auto home it will move gantry to basically centre of the build plate then move print head to the centre of the of the build plate and probe the Z just the same as my other printer. if you do auto home again it will move the print head to the far left where it drives the touch against the gantry wheels and stalls out. The last firmware I installed was the CR Touch Firmware Version for 32-bit Motherboard from the Creality accessory page. I have since installed the stock firmware from the same site, the printer works but no auto level. same site the printer works

Marlin 2.0.1 v1.o.1 end stop. This is what I installed.

To post a picture; take the picture with whatever camera you are using, copy the picture the device you are using the forum on then drag and drop the picture into your post.

Alternatively, click the picture icon at the top of the text entry screen when posting a message. It’s in the middle of the icons. Then direct it to where the picture is stored. It saves you a thousand words.

Hah didn’t know how to do this. Thanks now I hope this helps. Jason asked what version if firmware I tried but I tried several hope you can steer me to one that works.
Thanks for the help. I f this is going to the wrong person perhaps you could forward.
Thanks again.

Before I forget, the photos show the Z end stop switch connected. It was disconnected at the switch or at the board or both for all the setups. The only thing I didn’t do was to remove the wire completely.

I installed the Touch system on my pro without issue. Your wires looks right. Which firmware did you install?

Once my firmware was installed it worked a charm.


The photo shows the correct firmware to install based on a 4.2.2 board and your wiring.

Good luck, Cheers!

1 Like

I did notice something just going to note here, THe order of the wiring for the CRtouch looks wrong to me, Should be Brown, Red,Yellow,Black,White. Port is labeled G,V,IN,G,OUT. Looks like the plug may be inverted? Cannot say 100%

Seems to me I tried that one but couldn’t get it to work. Guess I am too stupid for the CR Touch installation. I only wish the instructions were printed in a size that that could be read without a magnifying glass. I checked the wiring harness the colours are Blue Red Yellow Black White. It is printing at the moment so I didn’t check the pinout on the board.

Trinity gave me a firmware number but that is the one I tried last. I couldn’t get it to work. I was thinking of sending a video of the motions. Think that would help?

HI @vernonmr absolutely, Pics or videos always help

Here is a photo of the cable end i got with my CR touch kit that i installed on a Pro5. This cable worked perfectly with the CR touch and also tested with the BL touch. You can check the wire colours.

I suspect he may have initially loaded the wrong firmware, and now it doesnt want to take another update without the date of the file being moved ahead. This is just my two cents.

However, that is a known working cable that came with the CR touch.


1 Like

I checked the colours and they are the same and in order. At the Touch. I haven’t checked the board end as am currently printing. I will check when the print is finished.

Went through the CR instructions and some Youtube videos I got it to print but the Z stop was too high. I readjusted the Z stop but now the hot end goes to the extreme left I went through the settings again and the hot end still goes to the left. What did I do wrong?

hi @vernonmr

After installing a BLtouch, I usually have to update my M851 to tell it where the nozzle is in ref to the BL.

The usual command is M851 X-39 Y-9

Hope this helps

Where do I set this command? I went to Cura ender 5 settings printer manage printer and could not find an M851 command to change and I don’t know where to install it.

Oh Sorry about that, You would have to connect to your printer via USB cable and pronterface.

Pronterface is basically a serial terminal that will allow you to ender commands directly into your 3d printer.
Link for the software is here

Downloaded installed Pronterface. Sent M command tried to print a print tower for PETG that I wanted to try. Printer jammed up so I tried again and took a video. If I can send it to where do I send it.